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B&Q Marketplace

B&Q Marketplace Intro and
APl Credentials

With NCompass 11.10 onwards you are able to link the B&Q Marketplace to NCompass.
This allows you to sync offers, download orders and provide order updates directly from
NCompass.

To get started the B&Q marketplace integration needs 3 pieces of information for you to enter into
NCompass for it to link to the store:

o APl Key
e API Endpoint
e Store ID

This part of the guide will cover how to get this information so you can enter it into the
corresponding configs on NCompass

B&Q API Credentials

B&Q - Sign in

Once signed in we can get all the information we need for NCompass

1 - APl Endpoint

The APl endpoint is the standard B&Q APl Endpoint as listed in the documentation. take note of
this URL

https://marketplace.kingfisher.com/api



https://marketplace.kingfisher.com/login
https://marketplace.kingfisher.com/api

2 - Store ID

The Store ID is gathered from the B&Q Store dashboard, this is required for any API calls to B&Q.

After signing in, you will be redirected to the following screen.

Payment
Pending balance £0.00 Payable balance £0.00
Next billing date: 01/09/2025
Activity Last7days~ Filters & GMV - Shipped orders  Taxes excluded, shipping charges included

Performance overview

Active ofters

Paid balance

23/08 25/08 27/08

® cmv Active offers

GBP 6
GBP 5
GBP 4
GBP 3
GBP 2
GBP1
GBPO

& Orders

0 late orders

0 orders awaiting
shipment

0 orders pending
acceptance

® Incidents

0 disputed incidents

0 new incidents

0 incidents in progress

¥ Messages

0 unread

You will need to take note of the location in the screenshot above, this is the store ID

The store ID in the screenshot above is only an example

3 - APl Key

Main Dashboard

KD

+ Add offer

View
View

View

View
View

View

View

Stay on the Dashboard for B&Q. You will need to press on the profile icon in the top right, then

press on "Personal settings"
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Personal Settings Page

once on this page, press on APl key

Personal settings

API key Motification preferences Recent sign-in activity

Notification preferences

Select the notifications you want to receive by email.

Order notifications
Offer notifications

Shop administration notifications

Generate API Key

View

View

View

View

View

View

View


https://kb.findesolutions.com/uploads/images/gallery/2025-07/WgccO8hpwTzqzewX-image.png
https://kb.findesolutions.com/uploads/images/gallery/2025-07/1ASf8vqbDUFE2GaC-image.png

After you reach the API Key page, simply press on Generate new key. This will create an API key for
the marketplace.

API key

ey I Copy to clipboard

" Generate new key

Copy the API Key to clipboard and store somewhere safely for the time being. This has to be kept
secure.

You now have the API key and other details and can move on
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B&Q Marketplace

Creating a New Marketplace

When setting up a new Marketplace you only need to configure a few settings within NCompass to
activate a new Marketplace. This will vary sightly between different marketplace integrations. this
guide will follow the general steps for the B&Q integration.

Create a new Web-Site

We will need to create a brand new web-site within NCompass where we will assign the integration
type and select the Marketplace Channel.

Step 1 - Making a new Web-Site

On NCompass, go under Administration > Multi-Channel > Web Sites

Create a new website by pressing "New". Give it a descriptive name and select a corresponding
price category to list product pricing under.

Set the Channel Type to "Marketplace"

Select the integration type (in this case B&Q)



o Web-sites - Manage Multiple Sit o [@ )3

Configured Sites Website Settings
[Web Site] General Products And Stock Customer APl Pricing

Amazon 1
Amazon 2

Amazon 3 Description: B&Q

Price Category: Retail i

Primary Domain:

|:l-';"||.:'b' Evolution
Panasonic UK Default Marketing Source:

Root Department: Al Departments -
Channel Type:  Marketplace bl
Integration Type: B&OQ
Web Store ID
] Currency:
] Override VATRate:
] Sync Monitor Site 1D
Web Domain Code:  ‘Generated on save

This is only generated when you sawe a new entry - you will need to give this code
to your web-site integrator if inking a web-site to NCompass

Sync Status:

[ ] Standardise Case [ | Expired Cancel Save

Press save and you can move on to the next step.

Other settings are optional, this guide is covering the bare minimum setup to
link a marketplace

Step 2 - Set Marketplace Settings

Go Back to Administration > Multi-Channel > Marketplace Settings

Select the new Marketplace Web-Site name you've just created and press Edit > (It will appear if
you chose marketplace channel type on Web-sites administration)

You can update the description here and ensure the integration matches the one set within web-
sites

Make sure the marketplace is enabled

The following settings are needed for API calls to B&Q:

1. APl Endpoint
2. Shop ID
3. API Auth Key
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) Marketplace Setting o [ =@
Configured Sites Marketplace
(N Description:  B&Q Integration: B&Q ~ B Enabled
Sattings
Search
Setting Default Global Marketplace
Allow Back Orders No O O
AP Auth Key 0 [ ——
AP| Endpoint O B nittps.imarketplace kingfisher com/api
Auto Accept Al Orders Yes 0O U
Branch For Orders 0 ()]
Default Finance House For Payments [ f :|
Delivery Lead Time For Back Orders O )]
Deiivery Lead Time For Items In Stock O O
Deiivery Product [ )]
Do Offer Syne Yes O g
Do Order Download Sync Yes 0 @]
Do Order Update Sync Yes O ]
Hours To Look Back For Orders 48 O O
Max Stock Level O [
Maximum Lead Time [ O
Offer Sync Frequency (Mins) 1 0O O
Order Download Sync Frequency (Mins) 5 [_ \'_'I
Order Update Syne Frequency (Mins) 5 O O
Remove Offers If Zero Stock No O &)
Salesparson For Orders 0 O
Shop ID O @ 1234
Stock Offset O &)
Ciose ) Expired Cancel Save

All you need are the 3 settings above for the minimum B&Q setup

The vast majority of marketplace configs will be present within this Tab instead of Tools >
Config

Final Considerations:

e Create an unmatched product, ensure there is an unmatched web product linked to an
actual unmatched item otherwise downloaded orders without a product link will return a
BLANK sundry line
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B&Q Marketplace

Marketplace Settings

The minimum setup to send offers should have been completed when
the API credentials were entered under marketplace settings. You
should have the ability to create and update offers.

This leaves the other marketplace settings which you would want to configure. | have listed the
important configs to setup at the top of this guide. The Guide is referencing the section under
Administration > Multi-Channel > Marketplace Settings.

B = ==
Configured Sites Marketplace
CEF Description:  B&Q Integration:  B&Q z B Enabled
Settings
Search
Setting Default Global Marketplace
Allow Back Orders No O O
API Auth Key ) P ——
API Endpoint | B htips/imarketplace kingfisher com/api
Auto Accept All Orders Yes C O

Branch For Orders

Default Finance House For Payments | L
Delivery Lead Time For Back Orders

Delivery Lead Time For Items In Stock [

Deivery Product

Do Offer Sync Yes C J
Do Order Download Sync Yes L [ |
Do Order Update Sync Yes | L
Hours To Look Back For Orders 48 [l B
Max Stock Level [

Maximum Lead Time

Offer Sync Frequency (Mins) 1 O
Order Download Sync Frequency (Mins) 5
Order Update Sync Frequency (Mins) 5 L
Remove Offers If Zero Stock No

Salesperson For Orders L

Shop ID B 1234
Stock Offset ] O

Close [ Expired Cancel Save

Important settings

Marketplace Config Summary Example Input
(---Do not copy these 1 for 1---)
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Allow Back Orders

Branch For Orders

Default Finance House

Salesperson For Orders

Offer Sync Frequency (Mins)
Order Download Sync Frequency
(Mins)

Order Update Sync Frequency (Mins)

Do Offer Sync
Do Order Download Sync

Do Order Update Sync

Delivery Product

Other Settings

Marketplace Config

Auto Accept All Orders

Delivery Lead Time For Back Orders
Delivery Lead Time For Items In Stock

Hours To Look Back For Orders

The ability to list product without
them being in stock. However, you
need to have either Purchase Orders
with expected due dates or Supplier
Stock Availability for this to work.

Which branch to set Web orders
against by default

Which finance house should be used
for Web order payments from the
Marketplace

The Salesperson Web orders get set
against

How often ServerGUI checks for offer
updates in minutes

How often ServerGUI checks for new
orders in minutes

How often ServerGUI checks for order
updates in minutes

Should ServerGUI update offers
Should ServerGUI download Orders

Should ServerGUI send Order Status
Updates to Marketplace

If the NCompass pulls down an
alternate form of shipping/delivery
under the Web order, this is the
delivery product it will use by default.

Summary

A config dedicated to evolution, you
need to "Accept" orders from their
site before you receive payment.

Not working currently

The lead time for delivery on items
which are on Back Order

The lead time for delivery on items in
stock

How far back to look for new Orders

Yes

Head Office

B&Q Finance House

B&Q

Yes
Yes

Yes

(Short code number) 219978

Example Input
(---Do not copy these 1 for 1---)

Yes

48



Marketplace Config

Max Stock Level

Maximum Lead Time

Remove Offers If Zero Stock

Stock Offset

Summary

What is the highest stock amount you
will send to the marketplace.

If you have items on backorder, what
is the maximum lead time you will
offer for any product. It will not offer
items above this set lead time

Whether ServerGUI should send offer
delete requests when you have 0
stock in the system for an item.

How much to offset stock by when
sending offer updates

Example Input
(---Do not copy these 1 for 1---)

--Leave Unset--

10

No

This guide is made on 05/09/2025 the integration may be subject to change and there may
be more settings after this date.



B&Q Marketplace

Creating Marketplace Offers

Creating marketplace offers is done under the Web/Online Details tab
of a product, managed next to all other web sections.

Product Enquiry > Search for a product > Right click product > Select Web/Online Details >
Navigate to Marketplace Tab

® Web + multi-channel settings for TLC 65Q6C 65Inch 4K Uhd Mini Led Smart TV Wifi Google TV [ @ [=]
Images and Main Content Amazon eBay FEuronics Default Web Content Ma@m
(] Marketplace: () Show Expired Prices...
View Product
Marketplace Product ID Offer ID Start Date End Date Online

G N Markelplace:
Add Using Product ID: Check
Edit
Offer ID: I
Delete Will be generated if left blank
Setting Default Offer
Allow Back Orders Mo
Delivery Lead Ti... I
Starts:  0309/2025 0000 'S pelivery Lead Ti..
Ends:  03/09/2025 0000 %  Max Stock Level e
Expired Cancel Save
Save

After reaching this tab, to create an offer you just need to press "Add New"

Select the marketplace of your choosing.
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If B&Q is selected it will auto populate the Product ID using EAN - You can press "Check" to see if
this is a B&Q catalogue product (This checks with B&Q to see if its an available product in the

existing catalogue)

You can then enter a pre-existing offer ID to link an active B&Q offer or leave it blank and

NCompass will create a new one

NCompass does not auto-link offers, they either need to be created or manually linked by

entering offer ID

B&Q Marketplace links all products using EAN

You can then press Save to create the offer -

Images and Main Contert Amazon eBay Euronics Default Web Content  Markelplaces

("] Marketplace: ("] Show Expired Prices..
View Product
Marketplace Product ID Start Date End Date Offer ID Oniine

Web Review...

Add New Marketplace: B&O s
Add Using ProductiD: 8806097413530 Check | Samsung UEB5SUBD20FKXXU 65inch Crystal UHD 4K
Locked to product EAN
Edit
Dffer Ik Search:
Delete Will be generated if left blank
Setting Default Offer
Allow Back Orders Mo O
Delivery Lead Ti... OJ I
[ stats:  08/09:2025 0000 T Delivery Lead T 0
[JEnds:  psroazo2s 0000 T Max Stock Level O Cancel
red Cancel Save
(] Expi —

The offer settings in the bottom right are optional.
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Notes:

You can have multiple offers for the same product for the same marketplace. (2 or more B&Q
offers)



B&Q Marketplace

Downloading Marketplace
Offers

Downloading Marketplace Orders is handled by the NCompass
ServerGUI process, however some settings need to be configured for
this to work.

The configs within the marketplace will work by default, importing brand new orders within 48
hours of them being placed. You can change this through marketplace settings.

Anything server related will have to be done by support

o [@s

Configured Sites Marketplace
[BaciReliant | Description:  B&Q Refiant Integration: B&0 & Enabled
Saltings
Search
Setting Default Global Marketplace
Allow Back Orders No 8 B ne
API Auth Key a ] rre—
API Endpoint B https:imarketplace kingfisher. com/api
Auto Accept Al Orders Yes ) O
Branch For Orders O B site1
Default Finance House For Payments B eza

Delivery Lead Time For Back Orders

Delivery Lead Time For Items In Stock ]

Delivery Product [ o o2
Do Offer Sync Yes ] B ves
Do Order Dowrload Sync Yes O B ves
Do Order Update Sync Yes (] B ves
Hours To Look Back For Orders 48 _ [
Max Stock Level [ | [
Maximum Lead Time [ - il
Offer Sync Frequency (Mins) 1 a B8
Order Download Sync Frequency (Mins) 5 - . 3
Order Update Sync Frequency (Mins) 5 ] B85
Remove Offers If Zero Stock No ] ]
Salesperson For Orders [ B Salesperson
Shop ID B 4930
Stock Offset [ U
Close [ Expred Cancel Save

Relevant Configs:

Hours To Look Back For Orders - How far back ServerGUI will look back on B&Q for orders to import

Order Download Sync Frequency - How often ServerGUI checks for new orders in minutes
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Default Finance House For Payments - Which finance house is chosen for NCompass Marketplace
order payments

Delivery Product - Which NCompass product gets assigned to Web orders for marketplace delivery
products

Salesperson For Orders - The Salesperson which gets selected against Web orders



B&Q Marketplace

Marketplace Order Updates

You can send order updates to the B&Q Marketplace through NCompass. NCompass will handle this
automatically as long as the process is followed.

There is only one order status update for B&Q which can be sent. This is sending the order
status update of "Shipped" after completing a field call linked to the imported sale.

After a B&Q order is imported into NCompass, the customer will be booking a field call for the
order. Once this field call is marked as "Completed" NCompass will queue to send a "Shipped"
status update to the associated WebOrder.

Steps: Open NCompass B&Q Web order > Book field call > Mark field call as completed
> NCompass sends update

Relevant Settings:

Order Update Sync Frequency - how often to send order updates in minutes

--- This is all for the B&Q Integration ---

If you're not sure call into Support to ask for more information 01892 342 916



tel:+441892342916

Euronics Marketplaces
Service Import

https://www.youtube.com/embed/Ptu7A1HZH887?si=62E jaYWUWiczofz

A how-to video for importing your Euronics Marketplace services.

The template file for importing can be found here: Euronics Marketplace Full Service List.xlsx - click
on File > Create a Copy > Download a Copy to save a copy to your PC.

Extra Support

If you'd like additional help or support, the Calculus Support team are standing by to assist. Simply
book a session with an engineer on the service booking page, please note that additional charges

may apply.
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